Friday, May 18, 2007

Resolving Workflow Status Stopped when sending mail to a Sharepoint Group

There is a mysterious stalemate occurs when you create a normal sharepoint Designer workflow with An action of sending a mail to a sharepoint group. The workflow runs fine when run under Administrator Account but shows status stopped when run under any other account like Contributor etc.


This occurs due to the fact that by default, the visibility of members of sharepoint group is granted only To the members of those group. Any other user outside that group cannot enumerate the members of the group And hence the workflow fails with the status as stopped. To resolve the issue, Go to Sharepoint Group settings And allow Everyone to see the members of group.


This issue engrossed my whole day due to the fact that, there is no error reported when this occurs.

7 comments:

Bob said...

Thanks for figuring this out. I just ran into it myself and was stumped.

Anonymous said...

Thanks mate !

Zohaib

Greg said...

You just cured one serious headache, Thanks.

IT Samurai said...

I'm using WSS 3.0. Configuration on mine was actually enabled view from everyone but after click OK to escape a page then work fine now.
Thanks!!

Steve said...

Saved me hours of pain! thanks!

Tarcísio Gambin said...

You saved me a little headache =]
Could I publish this tip on my blog?? But of course giving all credits for you!

Tarcísio Gambin said...

You saved me a little big problem =]
Could I publish this tip on my blog?? But of course giving all credits to the author!